Home | Software Map | Motif Forums | Bug Home sponsored by ICS 
Bugzilla Bug
  1526
     Query page      Enter new bug
Bug#:1526 Platform: Version:
Product: OS: Reporter:ihayvuk@ics.com (Ihor Hayvuk)
Status: RESOLVED Priority: Cc:
Resolution: INVALID Severity: Component:
Assigned To: ihayvuk@ics.com (Ihor Hayvuk) Target Milestone:
URL:
Summary:
Attachments: Create a new attachment (proposed patch, testcase, etc.)
Bug 1526 depends on: Show dependency tree
Show dependency graph
Bug 1526 blocks:
Votes for bug 1526:    Vote for this bug

Additional Comments:


Leave as RESOLVED INVALID
Reopen bug
Mark bug as VERIFIED
Mark bug as CLOSED

View Bug Activity Format For Printing
Description: Opened: 2010-08-31 08:46

Since the release of xorg 7.5, open-motif's mwm seems to freeze when
clicking between windows.

Clicking on window borders is fine, but when clicking in the windows
contents in order to switch focus, xorg seems to completely freeze. I then
need to terminate x11.


------- Additional Comments From Ihor Hayvuk 2010-09-17 06:58 -------
On earlier servers mwm will receive a button press and release event. On current
servers, mwm receives only the release.
Mwm leaves the user with a stuck grab because it expects the press event to be
delivered unconditionally.

Let me illustrate this. Have a look at the code from clients/mwm/WmKeyFocus.c.

---- cut here ----
void DoExplicitSelectGrab (Window window)
{
    WmGrabButton (DISPLAY, FOCUS_SELECT_BUTTON, 0, window,
	False, ButtonReleaseMask, GrabModeSync, GrabModeSync, None,
	None);

} /* END OF FUNCTION DoExplicitSelectGrab */

---- cut here ----

WmGrabButton() is a wrapper for XGrabKey(), so the parameters are all the same.
If we pass ButtonReleaseMask to the sixth parameter using bitwise inclusive OR,
mwm will work fine.

The issue is addressed to xorg. Here is patch for xserver
http://cgit.freedesktop.org/xorg/xserver/commit/?id=1884db430a5680e37e94726dff46686e2218d525


------- Additional Comments From Ihor Hayvuk 2010-09-17 07:08 -------
I am sorry, should be ButtonPressMask it the comment above. So sixth parameter
should be ButtonReleaseMask | ButtonPressMask.

     Query page      Enter new bug
This is Mr. Samsa: the Open Motif bug system using Bugzilla. For more information about what Bugzilla is and what it can do, see mozilla.org's bug pages.
New | Query | bug # | Reports | New account | Log in