Home | Software Map | Motif Forums | Bug Home sponsored by ICS 
Bugzilla Bug
  1330
     Query page      Enter new bug
Bug#:1330 Platform: Version:
Product: OS: Reporter:kjh@flyballdogs.com
Status: CLOSED Priority: Cc:
Resolution: DUPLICATE Severity: Component:
Assigned To: openmotif-devel@motifzone.net Target Milestone:
URL:
Summary:
Attachments: Create a new attachment (proposed patch, testcase, etc.)
Bug 1330 depends on: Show dependency tree
Show dependency graph
Bug 1330 blocks:
Votes for bug 1330:    Vote for this bug

Additional Comments:


Leave as CLOSED DUPLICATE
Reopen bug

View Bug Activity Format For Printing
Description: Opened: 2006-03-27 13:37

This bug is occurring with OpenMotif 2.3.0 beta 1 & 2 on both Fedora Core 5
(i386) and SLES 9.3 (x86_64).  I've not tested anywhere else.  

In one of our apps we have an XmList widget that is getting sized 5 pixels high
even though we have XmNvisibleItemCount set to 5.  I've traced the problem down
to a small bug in List.c function SetDefaultSize.  

In the branch where lw->list.itemCount == 0 and USE_XFT is defined there is a
check for
if (lw->list.MaxItemHeight) which appears to the the opposite of whats intended.
 Surely, this code meant to test if lw->list.MaxItemHeight was zero and then set
it to 1. 

Here's a small patch.  I'm not sure of the official way to submit patches since
the bugzilla "submit patch" button just takes me to some generic ICS page.

--- openmotif-2.3.0/lib/Xm/List.c.vizcount      2006-03-24 16:45:01.000000000 -0600
+++ openmotif-2.3.0/lib/Xm/List.c       2006-03-24 16:45:35.000000000 -0600
@@ -2672,7 +2672,7 @@
       XmRenderTableGetDefaultFontExtents(lw->list.font, &height, NULL, NULL);

       lw->list.MaxItemHeight = (Dimension)height;
-      if (lw->list.MaxItemHeight)
+      if (lw->list.MaxItemHeight == 0)
         lw->list.MaxItemHeight = 1;
 #else
       if (XmeRenderTableGetDefaultFont(lw->list.font, &fs))


------- Additional Comments From Yura Syrota 2006-03-29 07:56 -------

*** This bug has been marked as a duplicate of 1331 ***

     Query page      Enter new bug
This is Mr. Samsa: the Open Motif bug system using Bugzilla. For more information about what Bugzilla is and what it can do, see mozilla.org's bug pages.
New | Query | bug # | Reports | New account | Log in